31 lines
812 B
Diff
31 lines
812 B
Diff
From 67e9793d070ac5c8e83abbe95b9208533ffeadd0 Mon Sep 17 00:00:00 2001
|
|
From: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
Date: Sat, 11 Apr 2020 22:01:40 +0200
|
|
Subject: [PATCH] Add an option to disable the berkeleydb module
|
|
|
|
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
---
|
|
configure.ac | 6 ++++++
|
|
1 file changed, 6 insertions(+)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 841fd6732c..06c9a81f95 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -4280,6 +4280,12 @@ if test "$UUID" = "no"; then
|
|
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _uuid"
|
|
fi
|
|
|
|
+AC_ARG_ENABLE(berkeleydb,
|
|
+ AS_HELP_STRING([--disable-berkeleydb], [disable berkeleydb]),
|
|
+ [ if test "$enableval" = "no"; then
|
|
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _dbm"
|
|
+ fi])
|
|
+
|
|
AC_SUBST(PYDOC)
|
|
|
|
AC_ARG_ENABLE(pydoc,
|
|
--
|
|
2.34.1
|
|
|