31 lines
925 B
Diff
31 lines
925 B
Diff
From 25c900e81a2fc0bbe35e7c94e2e5028cfbf6582a Mon Sep 17 00:00:00 2001
|
|
From: Nicolas Cavallari <nicolas.cavallari@green-communications.fr>
|
|
Date: Wed, 22 Feb 2017 17:55:59 -0800
|
|
Subject: [PATCH] Add an option to disable openssl support.
|
|
|
|
Signed-off-by: Nicolas Cavallari <nicolas.cavallari@green-communications.fr>
|
|
---
|
|
configure.ac | 6 ++++++
|
|
1 file changed, 6 insertions(+)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index db33d567ad..42fe6c8f5a 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -4219,6 +4219,12 @@ AC_ARG_ENABLE(unicodedata,
|
|
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} unicodedata"
|
|
fi])
|
|
|
|
+AC_ARG_ENABLE(openssl,
|
|
+ AS_HELP_STRING([--disable-openssl], [disable openssl support]),
|
|
+ [ if test "$enableval" = "no"; then
|
|
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} ssl _ssl _hashlib"
|
|
+ fi])
|
|
+
|
|
AC_SUBST(TK)
|
|
AC_ARG_ENABLE(tk,
|
|
AS_HELP_STRING([--disable-tk], [disable tk]),
|
|
--
|
|
2.34.1
|
|
|